Sitelet https://web.archive.org/web/20210101122634/https://github.com/arangodb/arangodb/issues/13014
Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Restoring dump with system collections fails with non-root user #13014

Closed
Simran-B opened this issue Nov 10, 2020 · 3 comments
Closed

Restoring dump with system collections fails with non-root user #13014

Simran-B opened this issue Nov 10, 2020 · 3 comments

Comments

@Simran-B
Copy link
Contributor

@Simran-B Simran-B commented Nov 10, 2020

Reported by Rico in Community Slack

My Environment

  • ArangoDB Version: 3.7.3
  • Storage Engine: RocksDB
  • Deployment Mode:
  • Deployment Strategy:
  • Configuration:
  • Infrastructure:
  • Operating System:
  • Total RAM in your machine:
  • Disks in use:
  • Used Package:

Component, Query & Data

Affected feature:

arangorestore

Dataset:

Size of your Dataset on disk:

Replication Factor & Number of Shards (Cluster only):

Steps to reproduce

  1. Create dump with --include-system-collections
  2. Create user with Administrate permission for the respective collections (including system collections)
  3. Restore dump with --include-system-collections and --server.username <user> (do not use root)

Problem:
At specific collection, the process is terminated with error: connect() failed with #61 - Connection refused.
After many trials, turned out the problem happens if --include-system-collections true with --server.username other than root is used. Unclear whether this is a bug or feature.

Expected result:
Be able to restore dumps equally with root and <user> given that the latter has the necessary permissions.

@Simran-B
Copy link
Contributor Author

@Simran-B Simran-B commented Nov 12, 2020

Asked for additional information:

Can you clarify what the deployment type and operating system is?
Was the non-root user created before you took the dump, i.e. is it included in the dump's _users collection?
Also, is this in the default _system database or one that you created?

@maxkernbach
Copy link
Contributor

@maxkernbach maxkernbach commented Dec 2, 2020

Closing - could not reproduce the issue and no further information was provided by the user.

@goldsky
Copy link

@goldsky goldsky commented Dec 30, 2020

I am very sorry for the delayed response.
I didn't aware of the slack's notification.
This happened on cloud environment with arangodb 3.7.2-1 - community edition:

  • 1 agent
  • 2 coordinator
  • 2 db

You may try this:

  1. Database was created by root
  2. arangorestore by other user (with "Administrate" permission)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.