Restoring dump with system collections fails with non-root user #13014
Comments
|
Asked for additional information:
|
|
Closing - could not reproduce the issue and no further information was provided by the user. |
|
I am very sorry for the delayed response.
You may try this:
|
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Reported by Rico in Community Slack
My Environment
Component, Query & Data
Affected feature:
arangorestore
Dataset:
Size of your Dataset on disk:
Replication Factor & Number of Shards (Cluster only):
Steps to reproduce
--include-system-collections--include-system-collectionsand--server.username <user>(do not useroot)Problem:
At specific collection, the process is terminated with
error: connect() failed with #61 - Connection refused.After many trials, turned out the problem happens if
--include-system-collections truewith--server.usernameother than root is used. Unclear whether this is a bug or feature.Expected result:
Be able to restore dumps equally with
rootand<user>given that the latter has the necessary permissions.The text was updated successfully, but these errors were encountered: