Today, we ran dnf upgrade on two independent machines (one with Rocky Linux 8.10, one with Rocky Linux 9.5), which upgraded redis-stack-server.
After this upgrade, the redis-stack-server systemd service was stopped and its definition file got removed! 😰
For a fix, we had to remove and reinstall + reenable the service.
Updated from redis-stack-server-7.4.0_v1-1.rhel8.x86_64 to redis-stack-server-7.4.0_v2-1.rhel8.x86_64.
Log digest:
[root@server ~] dnf upgrade
..
redis-stack-server x86_64 7.4.0_v2-1.rhel8 Redis 54 M
..
Transaction Summary
============================================================================================================================================================================
Install 3 Package(s)
Upgrade 434 Package(s)
Remove 3 Package(s)
Total download size: 861 M
Is this ok [y/N]: y
Downloading Packages:
..
(436/437): redis-stack-server-7.4.0-v2.rhel8.x86_64.rpm 17 MB/s | 54 MB 00:03
..
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
..
Updating: redis-stack-server-7.4.0_v2-1.rhel8.x86_64 413/874
Running scriptlet: redis-stack-server-7.4.0_v2-1.rhel8.x86_64 413/874
..
Running scriptlet: redis-stack-server-7.4.0_v1-1.rhel8.x86_64 613/874
Cleanup: redis-stack-server-7.4.0_v1-1.rhel8.x86_64 613/874
Running scriptlet: redis-stack-server-7.4.0_v1-1.rhel8.x86_64 613/874
..
Verifying: redis-stack-server-7.4.0_v2-1.rhel8.x86_64 830/874
Verifying: redis-stack-server-7.4.0_v1-1.rhel8.x86_64 831/874
..
Upgraded:
..
redis-stack-server-7.4.0_v2-1.rhel8.x86_64 remi-release-8.10-1.el8.remi.noarch
..
Installed:
kernel-4.18.0-553.33.1.el8_10.x86_64 kernel-core-4.18.0-553.33.1.el8_10.x86_64 kernel-modules-4.18.0-553.33.1.el8_10.x86_64
Removed:
kernel-4.18.0-305.3.1.el8_4.x86_64 kernel-core-4.18.0-305.3.1.el8_4.x86_64 kernel-modules-4.18.0-305.3.1.el8_4.x86_64
Complete!
[root@server ~]# ps -ef | grep redis
root 2276828 2174420 0 11:58 pts/0 00:00:00 grep --color=auto redis
[root@cserver ~]# systemctl status redis-stack-server
Unit redis-stack-server.service could not be found.
[root@server ~]# sudo dnf install redis-stack-server -y
Last metadata expiration check: 0:00:53 ago on Do 09 Jän 2025 11:57:39 CET.
Package redis-stack-server-7.4.0_v2-1.rhel8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@server ~]# ls /etc/systemd/system/redis-stack-server.service
ls: cannot access '/etc/systemd/system/redis-stack-server.service': No such file or directory
# later: dnf remove redis-stack-server + dnf install redis-stack-server + systemctl enable redis-stack-server --now
We did do one modification (on both servers), we changed the service file (added Restart=always and RestartSec=1 in the service section), so that redis-stack-server restarts on fail (we sometimes experience OOM errors where the kernel kills random processes), but we do this regularly with multiple other packages too, this should not trigger a deletion of the service file.
Is this Github project the correct place for this issue? We can provide additional information if needed. Thank you!
Today, we ran
dnf upgradeon two independent machines (one with Rocky Linux 8.10, one with Rocky Linux 9.5), which upgraded redis-stack-server.After this upgrade, the redis-stack-server systemd service was stopped and its definition file got removed! 😰
For a fix, we had to remove and reinstall + reenable the service.
Updated from
redis-stack-server-7.4.0_v1-1.rhel8.x86_64toredis-stack-server-7.4.0_v2-1.rhel8.x86_64.Log digest:
We did do one modification (on both servers), we changed the service file (added
Restart=alwaysandRestartSec=1in the service section), so that redis-stack-server restarts on fail (we sometimes experience OOM errors where the kernel kills random processes), but we do this regularly with multiple other packages too, this should not trigger a deletion of the service file.Is this Github project the correct place for this issue? We can provide additional information if needed. Thank you!